const regex = /(\b)-\n(\b)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b)-\\n(\\b)', 'gmu')
const str = `Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);