#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(\b)-\n(\b)"
Local $sString = "Test test test te-" & @CRLF & _
"st test test." & @CRLF & _
"" & @CRLF & _
"Zażółć gęślą jaźń, zażółć gęś-" & @CRLF & _
"lą jaźń." & @CRLF & _
"— Pchnąć w tę łódź je-" & @CRLF & _
"ża i óśm skrzyń fig! — A po co, a dla kogo!" & @CRLF & _
"— Wszyscy gl*niarze to s*kinsyny!" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)