$re = '/(\b)-\n(\b)/mu';
$str = 'Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;