package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\d+,\s?)*(\d+)$`)
var str = `12345
1, 34, 12345, 5063
1 34 12345 5063
1,
0,
abscolkjs, js334, 5p3, 42324`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}