use strict;
my $str = '12345
1, 34, 12345, 5063
1 34 12345 5063
1,
0,
abscolkjs, js334, 5p3, 42324';
my $regex = qr/^(\d+,\s?)*(\d+)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}