using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=<tag[^>]*?type=[""']findMe[""'])";
string substitution = @"\n[break]\n";
string input = @"some html text <br> with some formatting<tag id=""1"" type=""dontFidMe"">sample text</tag> yada <tag id=""2"" type=""findMe"">sample text</tag>yada";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}