$re = '/(?=<tag[^>]*?type=["\']findMe["\'])/';
$str = 'some html text <br> with some formatting<tag id="1" type="dontFidMe">sample text</tag> yada <tag id="2" type="findMe">sample text</tag>yada';
$subst = "\n[break]\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;