import Foundation
let pattern = #"(?=<tag[^>]*?type=["']findMe["'])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"some html text <br> with some formatting<tag id="1" type="dontFidMe">sample text</tag> yada <tag id="2" type="findMe">sample text</tag>yada"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n[break]\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)