use strict;
my $str = 'some html text <br> with some formatting<tag id="1" type="dontFidMe">sample text</tag> yada <tag id="2" type="findMe">sample text</tag>yada';
my $regex = qr/(?=<tag[^>]*?type=["']findMe["'])/p;
my $subst = '\\n[break]\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";