import re
regex = re.compile(r"(?=<tag[^>]*?type=[\"']findMe[\"'])")
test_str = "some html text <br> with some formatting<tag id=\"1\" type=\"dontFidMe\">sample text</tag> yada <tag id=\"2\" type=\"findMe\">sample text</tag>yada"
subst = "\\n[break]\\n"
result = regex.sub(subst, test_str)
if result:
print(result)