#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S*\d+\S*"
Local $sString = "QQ Q638J205Y" & @CRLF & _
"/(?<=\s).*/gm" & @CRLF & _
"Получаем Q638J205Y" & @CRLF & _
"" & @CRLF & _
"А если строка такая" & @CRLF & _
"Skmei 1773BKBK black/black?" & @CRLF & _
"Нужно получть 1773BKBK" & @CRLF & _
"/(?<=\s).*(?=\s)/gm" & @CRLF & _
"так не ищет первый вариант." & @CRLF & _
"" & @CRLF & _
"Строка может быть и такой:" & @CRLF & _
"DANIEL KLEIN DK13402-4" & @CRLF & _
"Артикул тут DK13402-4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")