re = /\S*\d+\S*/m
str = 'QQ Q638J205Y
/(?<=\\s).*/gm
Получаем Q638J205Y
А если строка такая
Skmei 1773BKBK black/black?
Нужно получть 1773BKBK
/(?<=\\s).*(?=\\s)/gm
так не ищет первый вариант.
Строка може т быть и такой:
DANIEL KLEIN DK13402-4
Артикул тут DK13402-4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end