import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S*\\d+\\S*";
final String string = "QQ Q638J205Y\n"
+ "/(?<=\\s).*/gm\n"
+ "Получаем Q638J205Y\n\n"
+ "А если строка такая\n"
+ "Skmei 1773BKBK black/black?\n"
+ "Нужно получть 1773BKBK\n"
+ "/(?<=\\s).*(?=\\s)/gm\n"
+ "так не ищет первый вариант.\n\n"
+ "Строка может быть и такой:\n"
+ "DANIEL KLEIN DK13402-4\n"
+ "Артикул тут DK13402-4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}