using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*\d+\S*";
string input = @"QQ Q638J205Y
/(?<=\s).*/gm
Получаем Q638J205Y
А если строка такая
Skmei 1773BKBK black/black?
Нужно получть 1773BKBK
/(?<=\s).*(?=\s)/gm
так не ищет первый вариант.
Строка может быть и такой:
DANIEL KLEIN DK13402-4
Артикул тут DK13402-4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}