package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*\d+\S*`)
var str = `QQ Q638J205Y
/(?<=\s).*/gm
Получаем Q638J205Y
А если строка такая
Skmei 1773BKBK black/black?
Нужно получть 1773BKBK
/(?<=\s).*(?=\s)/gm
так не ищет первый вариант.
Строка может быть и такой:
DANIEL KLEIN DK13402-4
Артикул тут DK13402-4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}