// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S*\d+\S*").unwrap();
let string = "QQ Q638J205Y
/(?<=\\s).*/gm
Получаем Q638J205Y
А если строка такая
Skmei 1773BKBK black/black?
Нужно получть 1773BKBK
/(?<=\\s).*(?=\\s)/gm
так не ищет первый вариант.
Строка может быть и такой:
DANIEL KLEIN DK13402-4
Артикул тут DK13402-4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}