const regex = /\S*\d+\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*\\d+\\S*', 'gm')
const str = `QQ Q638J205Y
/(?<=\\s).*/gm
Получаем Q638J205Y
А если строка такая
Skmei 1773BKBK black/black?
Нужно получть 1773BKBK
/(?<=\\s).*(?=\\s)/gm
так не ищет первый вариант.
Строка может быть и такой:
DANIEL KLEIN DK13402-4
Артикул тут DK13402-4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}