# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/~\|~/\n|\n/g;t' <<< "1~|~Vijay~|~25~|~Pune"