use strict;
my $str = '1~|~Vijay~|~25~|~Pune';
my $regex = qr/~\|~/p;
my $subst = '\\n|\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";