import Foundation
let pattern = #"~\|~"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1~|~Vijay~|~25~|~Pune"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n|\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)