#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "~\|~"
Local $sString = "1~|~Vijay~|~25~|~Pune"
Local $sSubst = "\n|\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)