using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~\|~";
string substitution = @"\n|\n";
string input = @"1~|~Vijay~|~25~|~Pune";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}