import re
regex = re.compile(r"~\|~")
test_str = "1~|~Vijay~|~25~|~Pune"
subst = "\\n|\\n"
result = regex.sub(subst, test_str)
if result:
print(result)