import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<hour>\\d*\\:)(?P<min>\\d+)\\:(?P<sec>\\d+)";
final String string = "01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\'s still a lot of noise.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}