// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)").unwrap();
let string = "01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\'s still a lot of noise.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}