$re = '/^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)/m';
$str = '01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\\'s still a lot of noise.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);