use strict;
my $str = '01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\\'s still a lot of noise.';
my $regex = qr/^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}