const regex = /^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<hour>\\d*\\:)(?P<min>\\d+)\\:(?P<sec>\\d+)', 'gm')
const str = `01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\'s still a lot of noise.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}