re = /^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)/m
str = '01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\\'s still a lot of noise.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end