import re
regex = re.compile(r"^(?P<hour>\d*\:)(?P<min>\d+)\:(?P<sec>\d+)", flags=re.MULTILINE)
test_str = "01:24:55 And we still have to use Profiling sometimes to 0.2 0.5% 1%. That\\'s still a lot of noise."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")