#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Weapons\X*?\n(\X*)\n\n"
Local $sString = "[e85545]Weapons[-]" & @CRLF & _
"[c6c930]Ion Accelerator (Overcharge)[-]" & @CRLF & _
"72" Heavy 6 S:8 AP:-3 D:4 Sp:* " & @CRLF & _
"[c6c930]Ion Accelerator (Standard)[-]" & @CRLF & _
"72" Heavy 6 S:7 AP:-3 D:3 " & @CRLF & _
"[c6c930]2x Missile Pod[-]" & @CRLF & _
"30" Assault 2 S:7 AP:-2 D:2 " & @CRLF & _
"[c6c930]Plasma Rifle[-]" & @CRLF & _
"30" Assault 1 S:8 AP:-4 D:3 " & @CRLF & _
"[c6c930]Riptide Fists[-]" & @CRLF & _
"Melee S:+1 AP:-2 D:2 " & @CRLF & _
"" & @CRLF & _
"[dc61ed]Abilities[-]" & @CRLF & _
"Drone Shield Generator" & @CRLF & _
"Counterfire Defence System" & @CRLF & _
"Multi-tracker" & @CRLF & _
"Target Lock" & @CRLF & _
"Riptide Shield Generator" & @CRLF & _
"Explodes (Riptide)" & @CRLF & _
"Nova Reactor (Riptide)" & @CRLF & _
"Battlesuits" & @CRLF & _
"Manta Strike" & @CRLF & _
"Valued Sacrifice" & @CRLF & _
"Artificial Helpers" & @CRLF & _
"Limited Parameters" & @CRLF & _
"Docked Drones"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")