package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Weapons\X*?\n(\X*)\n\n`)
var str = `[e85545]Weapons[-]
[c6c930]Ion Accelerator (Overcharge)[-]
72" Heavy 6 S:8 AP:-3 D:4 Sp:*
[c6c930]Ion Accelerator (Standard)[-]
72" Heavy 6 S:7 AP:-3 D:3
[c6c930]2x Missile Pod[-]
30" Assault 2 S:7 AP:-2 D:2
[c6c930]Plasma Rifle[-]
30" Assault 1 S:8 AP:-4 D:3
[c6c930]Riptide Fists[-]
Melee S:+1 AP:-2 D:2
[dc61ed]Abilities[-]
Drone Shield Generator
Counterfire Defence System
Multi-tracker
Target Lock
Riptide Shield Generator
Explodes (Riptide)
Nova Reactor (Riptide)
Battlesuits
Manta Strike
Valued Sacrifice
Artificial Helpers
Limited Parameters
Docked Drones`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}