import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Weapons\\X*?\\n(\\X*)\\n\\n";
final String string = "[e85545]Weapons[-]\n"
+ "[c6c930]Ion Accelerator (Overcharge)[-]\n"
+ "72\" Heavy 6 S:8 AP:-3 D:4 Sp:* \n"
+ "[c6c930]Ion Accelerator (Standard)[-]\n"
+ "72\" Heavy 6 S:7 AP:-3 D:3 \n"
+ "[c6c930]2x Missile Pod[-]\n"
+ "30\" Assault 2 S:7 AP:-2 D:2 \n"
+ "[c6c930]Plasma Rifle[-]\n"
+ "30\" Assault 1 S:8 AP:-4 D:3 \n"
+ "[c6c930]Riptide Fists[-]\n"
+ "Melee S:+1 AP:-2 D:2 \n\n"
+ "[dc61ed]Abilities[-]\n"
+ "Drone Shield Generator\n"
+ "Counterfire Defence System\n"
+ "Multi-tracker\n"
+ "Target Lock\n"
+ "Riptide Shield Generator\n"
+ "Explodes (Riptide)\n"
+ "Nova Reactor (Riptide)\n"
+ "Battlesuits\n"
+ "Manta Strike\n"
+ "Valued Sacrifice\n"
+ "Artificial Helpers\n"
+ "Limited Parameters\n"
+ "Docked Drones";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}