# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Weapons\X*?\n(\X*)\n\n"
test_str = ("[e85545]Weapons[-]\n"
"[c6c930]Ion Accelerator (Overcharge)[-]\n"
"72\" Heavy 6 S:8 AP:-3 D:4 Sp:* \n"
"[c6c930]Ion Accelerator (Standard)[-]\n"
"72\" Heavy 6 S:7 AP:-3 D:3 \n"
"[c6c930]2x Missile Pod[-]\n"
"30\" Assault 2 S:7 AP:-2 D:2 \n"
"[c6c930]Plasma Rifle[-]\n"
"30\" Assault 1 S:8 AP:-4 D:3 \n"
"[c6c930]Riptide Fists[-]\n"
"Melee S:+1 AP:-2 D:2 \n\n"
"[dc61ed]Abilities[-]\n"
"Drone Shield Generator\n"
"Counterfire Defence System\n"
"Multi-tracker\n"
"Target Lock\n"
"Riptide Shield Generator\n"
"Explodes (Riptide)\n"
"Nova Reactor (Riptide)\n"
"Battlesuits\n"
"Manta Strike\n"
"Valued Sacrifice\n"
"Artificial Helpers\n"
"Limited Parameters\n"
"Docked Drones")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.