using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Weapons\X*?\n(\X*)\n\n";
string input = @"[e85545]Weapons[-]
[c6c930]Ion Accelerator (Overcharge)[-]
72"" Heavy 6 S:8 AP:-3 D:4 Sp:*
[c6c930]Ion Accelerator (Standard)[-]
72"" Heavy 6 S:7 AP:-3 D:3
[c6c930]2x Missile Pod[-]
30"" Assault 2 S:7 AP:-2 D:2
[c6c930]Plasma Rifle[-]
30"" Assault 1 S:8 AP:-4 D:3
[c6c930]Riptide Fists[-]
Melee S:+1 AP:-2 D:2
[dc61ed]Abilities[-]
Drone Shield Generator
Counterfire Defence System
Multi-tracker
Target Lock
Riptide Shield Generator
Explodes (Riptide)
Nova Reactor (Riptide)
Battlesuits
Manta Strike
Valued Sacrifice
Artificial Helpers
Limited Parameters
Docked Drones";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}