import Foundation
let pattern = #"Weapons\X*?\n(\X*)\n\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[e85545]Weapons[-]
[c6c930]Ion Accelerator (Overcharge)[-]
72" Heavy 6 S:8 AP:-3 D:4 Sp:*
[c6c930]Ion Accelerator (Standard)[-]
72" Heavy 6 S:7 AP:-3 D:3
[c6c930]2x Missile Pod[-]
30" Assault 2 S:7 AP:-2 D:2
[c6c930]Plasma Rifle[-]
30" Assault 1 S:8 AP:-4 D:3
[c6c930]Riptide Fists[-]
Melee S:+1 AP:-2 D:2
[dc61ed]Abilities[-]
Drone Shield Generator
Counterfire Defence System
Multi-tracker
Target Lock
Riptide Shield Generator
Explodes (Riptide)
Nova Reactor (Riptide)
Battlesuits
Manta Strike
Valued Sacrifice
Artificial Helpers
Limited Parameters
Docked Drones
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)