use strict;
my $str = '[e85545]Weapons[-]
[c6c930]Ion Accelerator (Overcharge)[-]
72" Heavy 6 S:8 AP:-3 D:4 Sp:*
[c6c930]Ion Accelerator (Standard)[-]
72" Heavy 6 S:7 AP:-3 D:3
[c6c930]2x Missile Pod[-]
30" Assault 2 S:7 AP:-2 D:2
[c6c930]Plasma Rifle[-]
30" Assault 1 S:8 AP:-4 D:3
[c6c930]Riptide Fists[-]
Melee S:+1 AP:-2 D:2
[dc61ed]Abilities[-]
Drone Shield Generator
Counterfire Defence System
Multi-tracker
Target Lock
Riptide Shield Generator
Explodes (Riptide)
Nova Reactor (Riptide)
Battlesuits
Manta Strike
Valued Sacrifice
Artificial Helpers
Limited Parameters
Docked Drones';
my $regex = qr/Weapons\X*?\n(\X*)\n\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}