#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|[12][0-9]|30|[0-9]{4})$"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"0" & @CRLF & _
"09" & @CRLF & _
"10" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"49" & @CRLF & _
"56" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"999" & @CRLF & _
"1000" & @CRLF & _
"0120" & @CRLF & _
"0001" & @CRLF & _
"9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")