re = /^([1-9]|[12][0-9]|30|[0-9]{4})$/m
str = '1
2
3
4
5
6
7
8
9
0
09
10
30
31
49
56
99
100
999
1000
0120
0001
9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end