import re
regex = re.compile(r"^([1-9]|[12][0-9]|30|[0-9]{4})$", flags=re.MULTILINE)
test_str = ("1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"0\n"
"09\n"
"10\n"
"30\n"
"31\n"
"49\n"
"56\n"
"99\n"
"100\n"
"999\n"
"1000\n"
"0120\n"
"0001\n"
"9999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")