const regex = /^([1-9]|[12][0-9]|30|[0-9]{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|[12][0-9]|30|[0-9]{4})$', 'gm')
const str = `1
2
3
4
5
6
7
8
9
0
09
10
30
31
49
56
99
100
999
1000
0120
0001
9999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}