#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w:\\\w+\\\w+\\(?<myfield>[^\.]+)"
Local $sString = "Fi a:\abc\def\MNOPQ.txt content is expected to include "A H Dis Query,0,0"" & @CRLF & _
"Fi a:\abc\def\APP.txt content is expected to include "A H Dis Query,0,0"" & @CRLF & _
"Fi a:\abc\def\WEB.txt content is expected to include "A H Dis Query,0,0""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")