$re = '/\w:\\\\\w+\\\\\w+\\\\(?<myfield>[^\.]+)/m';
$str = 'Fi a:\\abc\\def\\MNOPQ.txt content is expected to include "A H Dis Query,0,0"
Fi a:\\abc\\def\\APP.txt content is expected to include "A H Dis Query,0,0"
Fi a:\\abc\\def\\WEB.txt content is expected to include "A H Dis Query,0,0"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);