// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w:\\\w+\\\w+\\(?<myfield>[^\.]+)").unwrap();
let string = "Fi a:\\abc\\def\\MNOPQ.txt content is expected to include \"A H Dis Query,0,0\"
Fi a:\\abc\\def\\APP.txt content is expected to include \"A H Dis Query,0,0\"
Fi a:\\abc\\def\\WEB.txt content is expected to include \"A H Dis Query,0,0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}