import Foundation
let pattern = #"\w:\\\w+\\\w+\\(?<myfield>[^\.]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Fi a:\abc\def\MNOPQ.txt content is expected to include "A H Dis Query,0,0"
Fi a:\abc\def\APP.txt content is expected to include "A H Dis Query,0,0"
Fi a:\abc\def\WEB.txt content is expected to include "A H Dis Query,0,0"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)