const regex = /\w:\\\w+\\\w+\\(?<myfield>[^\.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w:\\\\\\w+\\\\\\w+\\\\(?<myfield>[^\\.]+)', 'gm')
const str = `Fi a:\\abc\\def\\MNOPQ.txt content is expected to include "A H Dis Query,0,0"
Fi a:\\abc\\def\\APP.txt content is expected to include "A H Dis Query,0,0"
Fi a:\\abc\\def\\WEB.txt content is expected to include "A H Dis Query,0,0"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}