using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w:\\\w+\\\w+\\(?<myfield>[^\.]+)";
string input = @"Fi a:\abc\def\MNOPQ.txt content is expected to include ""A H Dis Query,0,0""
Fi a:\abc\def\APP.txt content is expected to include ""A H Dis Query,0,0""
Fi a:\abc\def\WEB.txt content is expected to include ""A H Dis Query,0,0""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}