package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w:\\\w+\\\w+\\(?<myfield>[^\.]+)`)
var str = `Fi a:\abc\def\MNOPQ.txt content is expected to include "A H Dis Query,0,0"
Fi a:\abc\def\APP.txt content is expected to include "A H Dis Query,0,0"
Fi a:\abc\def\WEB.txt content is expected to include "A H Dis Query,0,0"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}