using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+";
string input = @"ABCD-012345-EFG-10vXRI47HU-1
ABCD-012345-EFG-10zSD0U/2
ABCD-012345-EFG-10ZsE8h -1
ABCD-012345-EFG- 10zSe9K
ABCD-012345-EFG-.10zSe9K
ABCD-012345-EFG-10zSe9K_2
ABCD-012345-EFG-10zSe9K.
ABCD-012345--EFG-10zSe9K
ABCD-012345-EFG-10zSe9K-
ABCD-012345-EFG-10zSe9K-//1/23h
ABCD-EFGH-HIJK-012345-10zSe9K
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}