import re
regex = re.compile(r"^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ABCD-012345-EFG-10vXRI47HU-1\n"
"ABCD-012345-EFG-10zSD0U/2\n"
"ABCD-012345-EFG-10ZsE8h -1\n"
"ABCD-012345-EFG- 10zSe9K \n"
"ABCD-012345-EFG-.10zSe9K\n"
"ABCD-012345-EFG-10zSe9K_2\n"
"ABCD-012345-EFG-10zSe9K.\n"
"ABCD-012345--EFG-10zSe9K\n"
"ABCD-012345-EFG-10zSe9K-\n"
"ABCD-012345-EFG-10zSe9K-//1/23h\n"
"ABCD-EFGH-HIJK-012345-10zSe9K\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")